博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
POJ 2367 Genealogical tree
阅读量:4693 次
发布时间:2019-06-09

本文共 2796 字,大约阅读时间需要 9 分钟。

换种颜色试试。。。。。
 
Genealogical tree
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2149 Accepted: 1457 Special Judge

Description

The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural. 
And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there's nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal. 
Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.

Input

The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member's children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.

Output

The standard output should contain in its only line a sequence of speakers' numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.

Sample Input

504 5 1 01 05 3 03 0

Sample Output

2 4 5 3 1

Source

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
bool mp[110][110];
int in_degree[110];
int N;
int main()
{
    scanf("%d",&N);
    memset(mp,false,sizeof(mp));
    memset(in_degree,0,sizeof(in_degree));
    for(int i=1;i<=N;i++)
    {
        int k;
        while(cin>>k)
        {
            if(k==0) break;
            mp[k]=true;
            in_degree[k]++;
        }
    }
    int ans[110];
    int cnt=0;
    while(cnt<N)
    {
        int i=1;
        for(i=1;i<=N;i++)
        {
            if(in_degree==0)
                break;
        }
        in_degree--;
        ans[cnt]=i;
        cnt++;
        for(int j=1;j<=N;j++)
        {
            if(mp[j])
            {
                in_degree[j]--;
            }
        }
    }
    for(int i=0;i<cnt;i++)
    {
        if(i!=0)
          printf(" ");
        printf("%d",ans);
    }
    return 0;
}

转载于:https://www.cnblogs.com/CKboss/p/3350973.html

你可能感兴趣的文章
filter 过滤器(监听)
查看>>
node启动时, listen EADDRINUSE 报错;
查看>>
杭电3466————DP之01背包(对状态转移方程的更新理解)
查看>>
kafka中的消费组
查看>>
python--注释
查看>>
SQL case when else
查看>>
SYS_CONTEXT 详细用法
查看>>
Pycharm配置autopep8让Python代码更符合pep8规范
查看>>
我的第一篇博客
查看>>
【C++算法与数据结构学习笔记------单链表实现多项式】
查看>>
C#垃圾回收机制
查看>>
31、任务三十一——表单联动
查看>>
python之hasattr、getattr和setattr函数
查看>>
maven使用阿里镜像配置文件
查看>>
Copy code from eclipse to word, save syntax.
查看>>
arguments.callee的作用及替换方案
查看>>
23 Java学习之RandomAccessFile
查看>>
P2709 小B的询问
查看>>
PHP echo 和 print 语句
查看>>
第一讲 一个简单的Qt程序分析
查看>>